Instalar PHP APCu en CentOS 6.9

Utilizando los repositorios de remi podemos instalar muy fácilmente APCu siguiendo este comando

sudo yum install php-pecl-apcu

Si os da este error con reiniciar apache o nginx es suficiente.

Installing : php-pecl-apcu-bc-1.0.3-6.el6.remi.7.1.x86_64 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/apc.so' - /usr/lib64/php/modules/apc.so: undefined symbol: zif_apcu_store in Unknown on line 0

Comentarios

Marcos Ramírez ha dicho que…
al querer actualizarlo me marca este error:

Error: Paquete: php-pecl-apcu-4.0.11-2.el6.x86_64 (epel)
Necesita: php(api) = 20090626
Instalado: php-common-5.6.35-0.el6.x86_64 (@AL-Server)
php(api) = 20131106-64
Disponible: php-common-5.3.3-49.el6.x86_64 (base)
php(api) = 20090626
Error: Paquete: php-pecl-apcu-4.0.11-2.el6.x86_64 (epel)
Necesita: php(zend-abi) = 20090626
Instalado: php-common-5.6.35-0.el6.x86_64 (@AL-Server)
php(zend-abi) = 20131226-64
Disponible: php-common-5.3.3-49.el6.x86_64 (base)
php(zend-abi) = 20090626
Podría intentar utilizar el comando --skip-broken para sortear el problema
Podría intentar ejecutar: rpm- Va --nofiles --nodigest
Reynier de la Rosa ha dicho que…
No sé cómo lo estas actualizando pero parece que necesitas una versión superior de php, intenta actualizar primero php.