Wamp 2 no funciona en Windows 7

Instalé el otro día wamp en mi ordenador con Windows 7 de 64 bits y para mi sorpresa al ejecutarlo no terminaban de levantar los servicios, buscando por internet la solución es bastante sencilla y es debido el fallo a una incompatibilidad en el trío WAMP + Windows 7 + Skype.

La solución la encontré en encodez y la traduzco al castellano, lo único que hay que hacer es modificar el archivo de configuración de apache en el wamp (conf.ini) con los siguientes cambios:

El archivo por defecto aparece de la siguiente manera:

#Listen ------:80
Listen 80

Dónde ------ es una dirección ip. El archivo tendría que quedar así:

Listen 127.0.0.1:80
#Listen 80

Comentarios

Dani ha dicho que…
Genial, gracias!
Probé a cerrar el Skype y también me funcionó!
Saludos.
Jaspher ha dicho que…
Hola y gracias por el aporte uso Windows 7, y elWampServer2.0i, pero logro hacer que funcione, su icono en la barra de tareas esta la mitad de amarillo y dice "1 de 2 servicios ejecutandose", pero lo que pasa es que no logro encontrar esas palabras de:
#Listen ------:80
Listen 80
en que archivo estan, en que directorio

porfavor responda, y gracias por la ayuda
tienes que buscar el archivo conf.ini en el directorio de instalación de apache dentro del wamp
Joey ha dicho que…
Se que el post es de hace mucho, pero como aparece en los primeros resultados de Dios, pues me ayudar al que llegue hasta aquí, para decirle que la versión de PHP 5.3.4 al parecer no rula en Windows 7 64. Solo tienen que cambiar la versión de PHP através del icono de wamp, en PHP/Versión/5.3.5. Así me ha resuelto el problema. Saludos!
Anónimo ha dicho que…
Buenas!!!

Muchas gracias por la informacion de este post me fue de gran utilidad!!!

Gracias!!!
Anónimo ha dicho que…
Muchas gracias, has evitado una gran comedura de cabeza
Clos132 ha dicho que…
hola, gracias por la info pero no encuentro ese archivo conf.ini, ademas no puedo desplegar el menu del inoco del wamp...
porfavor respondan, y gracias por la ayuda
Anónimo ha dicho que…
Que tal, probando diferentes soluciones de foros lo que logre, de la mejor manera fue cambiando de puerto para no tener conflictos con otros programas, para realizar el cambio correctamente seguir estos pasos.

1. instalar correctamente Wamp Server (mi caso: Version 2.1 )

2. una vez instalado localizar el archivo "httpd.conf" (ruta: C:\wamp\bin\apache\Apache2.2.17\conf\httpd.conf), abrirlo con el editor de texto menu ppal. -> edicion -> reemplazar y colocar en "buscar" el nro. 80 y en "reemplazar por" colocar el nro. 8080
Nota: las dos lineas que se reemplazan son "Listen 80" y "ServerName localhost:80" por "Listen 8080" y "ServerName localhost:8080".

4. localizar el archivo "wampmanager.tpl" ((ruta: C:\wamp\wampmanager.tpl) , abrirlo con el editor de texto menu ppal. -> edicion -> reemplazar y colocar en "buscar" -> "http://localhost/" y en "reemplazar por" colocar -> "http://localhost:8080/".
Nota: esto lo realizamos para que cuando se arranque el programa, en el menu de Wamp Server tome los valores correspondientes al hacer clic, por ejemplo, en "localhost", de esta manera me habre el explorador asi: "http://localhost:8080/".

Recuerden iniciar el programa "como administrador". El programa tiene que arrancar con o sin programas en ejecucion que utilicen el puerto 80, ejemplo: Skype.

Bueno, espero haberlos ayudado.

Saludos
Anónimo ha dicho que…
Mil Gracias Sr Anonimo, esto ultimo que publicaste (los 4 pasos)me funciono correctamente. Saludos.
Anónimo ha dicho que…
Buenas, ami tampoco me funcionaba el WAMPSERVER Version 2.2 en win 7. Lo que hice fue lo siguiente siguiendo obviamente los consejos de post. Abrimos WAMPSERVER, clic en el programa que se encuentra en la barra de tareas, Apache -> httpd.conf. En el archivo que se abre con el bloc de notas buscamos las lineas "# Listen xx.x.x.x:80" y "Listen 80" estas las cambiamos por lo siguiente "Listen 127.0.0.1:80" y "#Listen 80" respectivamente. Salvamos el archivo y listo. Espero sirva saludos.
Anónimo ha dicho que…
Gracias!! a mi me funciono la solución del anonimo del 7 de septiembre de 2011
Anónimo ha dicho que…
Como se llama el archivo donde esta eso de conf.ini, no logro encontrar la carpeta, y lo e buscado veces y veces
Reynier de la Rosa ha dicho que…
Anónimo el archivo se llama así conf.ini y debería estar en la carpeta de instalación de wamp, utiliza mejor el buscador de windows para encontrarlo.
Alumnos de la UNS ha dicho que…
Yo use WAMPSERVER Version 2.2 en win 7. y no funciona este proceso "# Listen xx.x.x.x:80" y "Listen 80" estas las cambiamos por lo siguiente "Listen 127.0.0.1:80" y "#Listen 80" respectivamente.

Si funciona:

1. instalar correctamente Wamp Server (mi caso: Version 2.2 en win7 )

2. una vez instalado localizar el archivo "httpd.conf" (ruta: C:\wamp\bin\apache\Apache2.2.17\conf\httpd.conf), abrirlo con el editor de texto menu ppal. -> edicion -> reemplazar y colocar en "buscar" el nro. 80 y en "reemplazar por" colocar el nro. 8080
Nota: las dos lineas que se reemplazan son "Listen 80" y "ServerName localhost:80" por "Listen 8080" y "ServerName localhost:8080".

4. localizar el archivo "wampmanager.tpl" ((ruta: C:\wamp\wampmanager.tpl) , abrirlo con el editor de texto menu ppal. -> edicion -> reemplazar y colocar en "buscar" -> "http://localhost/" y en "reemplazar por" colocar -> "http://localhost:8080/".

5.localizar el archivo "wampmanager.ini" ((ruta: C:\wamp\wampmanager.ini) , abrirlo con el editor de texto menu ppal. -> edicion -> reemplazar y colocar en "buscar" -> "http://localhost/" y en "reemplazar por" colocar -> "http://localhost:8080/".

Nota: Usar el remplazador de el bloc de notas poner "localhost" y cada ves k encontremos remplazarlo por "localhost:8080"; esto lo realizamos para que cuando se arranque el programa, en el menu de Wamp Server tome los valores correspondientes al hacer clic, por ejemplo, en "localhost", de esta manera me habre el explorador asi: "http://localhost:8080/".
tecmobeto ha dicho que…
Muchas gracias, si al parecer hace conflicto skipe, solo lo cerre y funciono perfectament

gracias hermano
Rkovac ha dicho que…
De gran ayuda el artículo junto con todos los comentarios. Gracias.
Anónimo ha dicho que…
muchas gracias hermano estuve rompiendome la cabeza todo el dia buscando soluciones al problema...gracias
Anónimo ha dicho que…
Hola, ya me funciona y el wamp se activa pero mi pagina de wordpress que ya tenia configurada antes del skype, ya no funciona alguien sabe como redirigir a wordpress al puerto 8080?
Anónimo ha dicho que…
esta solucion funciona:

Buenas, ami tampoco me funcionaba el WAMPSERVER Version 2.2 en win 7. Lo que hice fue lo siguiente siguiendo obviamente los consejos de post. Abrimos WAMPSERVER, clic en el programa que se encuentra en la barra de tareas, Apache -> httpd.conf. En el archivo que se abre con el bloc de notas buscamos las lineas "# Listen xx.x.x.x:80" y "Listen 80" estas las cambiamos por lo siguiente "Listen 127.0.0.1:80" y "#Listen 80" respectivamente. Salvamos el archivo y listo. Espero sirva saludos.
Gustavo Gonzalez ha dicho que…
Buenas, ojala alguien pueda ayudarme, parece que el wamp corre sin problemas, aparece en verde, pero cuando modifico mi index o cualquier otro html no se actualiza al instante incluso nunca, las fotos y demas no se cambian, y cuando la subo por filezilla si aparece actualizada, mi duda es por que en el wamp no se actualiza. saludos!
Reynier de la Rosa ha dicho que…
Tiene toda la pinta de que estas modificando los archivos fuera de la carpeta www de wamp.